I can't run ado. Message about wrong adopath.

#1
I installed this package
Menu-driven X-12-ARIMA seasonal adjustment in Stata
And i also installed the x12a64 package on my PC.
Its location is under "C:\Program Files (x86)"
But when i try to run it, it shows me this
x12a.exe not found, please make sure it is under the adopath!
The package's adopath file is sadopath.so and looks like
Code:
*! version 2011-Nov-23
* sapath "d:\seasonal adjustment/y1.out" "e:/pbc tj/y2.udg"
program sapath, rclass
version 11.0
syntax [anything]
if `"`anything'"' != `""' {
	tokenize `"`anything'"'
	local k=1
	while `"``k''"' != `""' {
		//dis "`k'; ``k''"
		local k=`k'+1
	}
	local k = `k'-1

	global prefmta ""
	forvalues i=1/`k' {
		local sk: word `i' of `anything'
		// dis "`sk'"
		tokenize `sk', parse("\/")
		local j=1
		while "``j''" != "" {
			//dis "`j'; ``j''"
			local j=`j'+1
		}
		local j = `j'-1
		local file "``j''"
		local len = length("`sk'")
		local lenf = length("`file'")
		local path = substr("`sk'", 1, `=`len'-`lenf'-1') // drop the last directory sepator
		if "`path'"=="" local path = "."
		tokenize `file', parse(".")
		global prefmta "$prefmta `1'"
		forvalues i=1/`k' {
			return local path`i' `"`path'"'
			return local file`i' `"`file'"'
		}
		return scalar nf = `k'
	}
}
end
I edited it changing x12a for x12a64 and i get nothing.
Always the same message. Can you tell me what i'm i doing wrong?
Thanks for your time and interest.
 
#3
I really want to thank you.
It worked your suggestion.
This is what i wrote in my do file and now i'm working with the data
Code:
adopath + "C:\Program Files (x86)\x12a"
Thanks again.
 

IHA

New Member
#4
Hello All,

I am trying to install and use x12a.exe in stata by following some suggested procedures in this website; however, it still reports the same error (x12a.exe not found, please make sure it is under the adopath!), I am afraid it is not running because I have mac!?

Thanks a lot
 
#5
Dear all,

I just try to use the mentioned command sax12, however, it returned*this error:

x12a.exe not found, please make sure it is under the adopath!

Then I added the path, by typing in my do file this:

adopath + "~/Library/Application Support/Stata/ado/"

Yet the command doesn't run and the error is the same. (By the way I found out the path searching it by the*viewsource sax12.ado)

I don't understand; if the problem is the path then by adding it the error should be solved, isn't it? Or is there any other*problem in the .ado file

Any suggestions?

Thanks in advance

Marly Tati