Installing Rcmdr into Rstudio on a Mac

I am trying to install the Rcmdr package into Rstudio on my mac but it keeps crashing as soon as I click the checkmark beside Rcmdr under the Packages tab and then click 'Install packages'. It seems to specifically crash when it tries to load the required package: splines. I tried loading the 'splines' package separately but that doesn't seem to help; after installing 'splines' separately (which works just fine), when I try to install Rcmdr, it still crashes Rstudio.

I have updated Rstudio to version 0.98.490 which according to is the latest version. I also did try installing X11 app, but my mac won't install it because "the image is not recognized".

What am I doing wrong?
Last edited:


Ambassador to the humans
Rstudio is just an interface to work with R.

However, it does change a few small things and I just think it's best to start by assessing if it's an issue with R or RStudio.
I tried installing Rcmdr in R rather than Rstudio, but again it crashed and asked me download the X11 app, which my mac will not allow me to do.
I was also not able to have rcmdr running with r 3.12 and yosemite os. I have installed xquartz, x11 and i still receive error messages when trying to run it.