installing rpud got unrecognized option '-Wl'

#1
I am trying to install the package rpud on a CENTOS Linux server and got the following error:

/usr/local/cuda/bin/nvcc -shared -Xlinker " -Wl,-rpath,/usr/local/cuda/lib64" -L/usr/local/cuda/lib64 -lcublas -lcuda rpud.o rpudist.o -o rpud.so
/usr/bin/ld: unrecognized option '-Wl'
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make: *** [rpud.so] Error 1
ERROR: compilation failed for package ‘rpud’
* removing ‘/usr/local/lib64/R/library/rpud’

The downloaded source packages are in
‘/tmp/RtmpbEKjuZ/downloaded_packages’
Updating HTML index of packages in '.Library'
Making 'packages.html' ... done
Warning message:
In install.packages("rpud") :
installation of package ‘rpud’ had non-zero exit status

I've tried and tried to remove the "-Wl" options from the config.site, configure, libtool, makefile, and makeconf (basically everywhere I could find it) on the R build directory and the source directory, but with no sucess. I still get the same error!

How can I eliminate this option? Or should I be using another linker than /usr/bin/ld?

Thanks in advance for your help!

Sincerely,
Roger
 
#5
I got the same problem you had. I'm trying to setup rpud under Ubuntu 14.04 LTS with R 3.0.2. But I still haven't found any solution to this issue. I was able to install rpud under Ubuntu 13.10 using CUDA 5.5, now I moved to CUDA 6.5 after the upgrade of my workstation and still get the issue you have.
 
#6
Once again I followed the instructions to the T and still the -Wl problem. I even tried to edit the Makefile and configure files and they keep sticking the -Wl option in.

Why, Oh Why doesn't anyone fix this? It would be so simple for them to take out the **** Wl and then we could all install it inside R.

It is lazyness? Lack of Concern? What?

Roger
 
#8
I am using Fedora 21. The latest R my repos have - R 3.20. I just downloaded a new copy of rpud. Cuda 7.0.

I've tried everything I can think of. I unzipped and untarred rpud. Removed every reference to Wl from all the config files and the Makefile before and after running configure. Ran install from the command line.

It still keeps sticking Wl in! I've never seen anything so pernicious! This problem has been going on for soooooooooo long - why hasn't anyone fixed it!

Roger
 

Dason

Ambassador to the humans
#9
Well -Wl is needed when passing arguments to a compiler that you need to be passed to the linker. If you look at the man page for ld they explain this. It's hard for me to work out how to fix your issue though since I've never run into what you're running into but my gut tells me that you shouldn't be messing with the makefiles. More than likely it's something else that is going wrong.