no observations r(2000)

#1
Dear all, I have just started using Stata for a time series analysis. However, there has already been to much failure before even started the acutal testing.

I imported certain time series data including a date variable. I managed to convert the data into stata accepted dates. When performing a Dickey Fuller Unit root test I get the error:

no observations
r(2000);

This is almost not possible, since when I "summarize" i get the following table:
Variable | Obs Mean Std. Dev. Min Max
-------------+--------------------------------------------------------
date | 0
i_spiindex | 141 1026.285 219.8331 573.86 1529.47
daten | 141 16769.21 1243.223 14640 18900

which clearly indicates that there are 141 observations.

and for the "describe" i get:
Contains data
obs: 141
vars: 2
size: 2,538 (99.8% of memory free)
-------------------------------------------------------------------------------
storage display value
variable name type format label variable label
-------------------------------------------------------------------------------
date str10 %10s
i_spiindex float %9.0g I_SPI Index
-------------------------------------------------------------------------------
Sorted by:
Note: dataset has changed since last saved

all this indicates that it is nummeric data I am using, but still it does not work at all.

has anybody had the same problem yet or knows how to deal with it? I really appreciate your help.

Many Thanks
Thomas
 
#3
hi

i typed in the following commands:

dfuller i_spiindex, trend lags(2)

varsoc i_spiindex, maxlag(10)

I think the problem is not so much the commands but moreover the problem with the data i imported. Additionally, i imported the data from a .txt file tab-deliminated

thanks a lot
 

bukharin

RoboStataRaptor
#4
Yes, I think you're right. I don't know anything about time series analysis, but generally this kind of problem occurs when a command is restricting the number of observations and the restriction ends up excluding all observations for some reason (which as you said, may point to a problem with the data). Does the -dfuller- command work if you run it without the trend and lags options?