OUTREG "varlist not allowed", "option 3aster not allowed"


New Member
I ran

outreg x y z g using blahblah, blahblah

It told me

"varlist not allowed"

So I just deleted all variables and just put

outreg using blahblah, blahblah

It told me

"option 3aster not allowed"

I did "ssc install outreg" to correctly install it.

I even uninstalled every package by ado uninstall[1], ado uninstall[2] and so on

and then did "ssc install outreg" again but it didn't work.

Can anyone provide some intelligent guess about how to fix this?

Thank you in advance.
Hello, I'm currently having the same problem. I ran my baseline regression as follows:

xtreg logfdigdp l_gdp l_loggdpcap l_loginflation l_logopenness_alt l_loggov_cons, fe r

And then tried to extract the results with outreg:

outreg using results, 3aster replace

Using this command, stata tells me that 3aster command is not allowed.

If I insert a variable to extract like this:

outreg l_gdp using results, 3aster replace

Stata says that varlist is not allowed.

Can somebody please help me with this? I have tried almost everything and searched solutions on the net, but found nothing to solve my problem.

I thank you in advance for any guess!



You need to differentiate between -outreg- and -outreg2-. They are completely different programs. As far as I can see you're using -outreg2- syntax with -outreg-. Your two options are:
1. adjust your syntax to work with -outreg-, see -help outreg-
2. install -outreg2- using -ssc install outreg2-
Thanks a lot! It worked. I downloaded outreg2 as well, but my thesis supervisor kept telling me that it should work with outreg, so I tried again and again, and indeed, I was using the wrong syntax.

Wish you the best!