R can't find inconsolata.sty


When I updated MikTex on Windows 7, R no longer would compile PDFs.

* checking PDF version of manual ... WARNING
LaTeX errors when creating PDF version.
This typically indicates Rd problems.
LaTeX errors found:
!pdfTeX error: pdflatex.EXE (file ts1-zi4r): Font ts1-zi4r at 540 not found
 ==> Fatal error occurred, no output PDF file produced!
* checking PDF version of manual without hyperrefs or index ... ERROR
This message details why:

A note from Prof. Brian D. Ripley

I tried the stuff he suggests but am not the most slick with this stuff.

Then I came across a post from Ian Fellows that says:

Ian Fellows said:
After installing the package, run the following steps from the inconsolata README:

initexmf --update-fndb
initexmf --edit-config-file updmap

The latter command should open updmap.cfg in your default editor, commonly Notepad. 
Add the line 

Map zi4.map 

to updmap.cfg, save and close. Then, in the command window, type

initexmf --mkmaps
Wanted to document this for other searchers.
Thanks! I eventually got around this issue by updating MikTex 2.9 at both the user AND the Administrator level, then running through your steps in the command prompt (CMD).

Solved, thanks for posting!


Global Moderator
That's funny, I had this problem yesterday. Resolved it by replacing MikTex as apparently they support inconsolata.sty again in the latest versions.